# Table of Contents

NETSCAPE/MOZILLA COMPOSER ......................................................................................... 5
Publisher: .......................................................................................................................... 5
Retail Cost: .......................................................................................................................... 5
System Requirements: ......................................................................................................... 5
Description ........................................................................................................................ 5
Getting Started .................................................................................................................. 6
Entering Text Content ........................................................................................................ 6
Adding Structure to Content .............................................................................................. 7
Defining Lists ..................................................................................................................... 9
Inserting Images .................................................................................................................. 11
Creating Data Tables ......................................................................................................... 13
WEB RESOURCES ........................................................................................................... 19
Downloads .......................................................................................................................... 19
Web Accessibility Information .......................................................................................... 19
Publisher:
Mozilla – http://www.mozilla.org/products/mozilla1.x/

Netscape – http://channels.netscape.com/ns/browsers/default.jsp

Retail Cost:
No cost for Composer. It is included with the Mozilla Internet Applications Suite or Netscape Internet Applications Suite.

System Requirements:
- Microsoft Windows 95 and greater
- Apple Macintosh 10.1.x and greater
- Linux 2.2.14 with the following libraries or packages minimums:
  - glibc 2.2.4
  - gtk+ - 1.2.0 (1.2.5 or greater preferred)
  - XFree86-3.3.6
  - Glib 1.2.x
- Linux is supported on Red Hat Linux 7.0 and greater

Description
Composer is a lightweight, WYSIWYG Web authoring tool that allows web authors to create Web pages quickly and easily. Its low cost (i.e., free) and simple authoring environment provides Web content creators with the necessary options to creating functional and usable websites without the need to learn a more complex Web authoring tool. Composer also provides a number of options that allows Web authors to include the necessary accessibility information in order to deliver accessible and usable Web content.

Composer is just one tool in the Mozilla Suite and Netscape Suite of Internet tools. For the purposes of this manual, all screenshots will be of the Mozilla version of Composer. While there is no difference in the functionality or the location of the various features, the "look" of the Composer interface may be slightly different if using Netscape versus Mozilla.
Getting Started

You will need to install either the Mozilla Suite or Netscape Suite of Internet tools, before you can open Composer and begin creating Web pages.

1. Select File from the menu bar and choose New.

2. Select Composer Page. This will create a new document in which you can begin creating Web pages.

Alternatively, you can press Ctrl+Shift+N to open a new Web document. You can do this from within the Mozilla/Netscape browser as well.

Entering Text Content

Composer is very similar to using a word-processor such as TextEdit or MS Word. Entering information into Composer is as simple as typing on the keyboard or copying and pasting from a word-processing application. Many of the same features that are available in word-processors are also available in Composer (e.g., inserting images, creating tables, spell-checking, etc.). Using a Web authoring tool, such as Composer, also allows the developer to include necessary HTML information that is not possible using word-processors.
For example, the text content "Hello World!" that appears in the Composer window above was entered by simply typing on the keyboard.

Adding Structure to Content

When creating a Web page, it may be necessary to impose some "structure" to the content. In other words, it may be necessary to distinguish between certain text elements such as headings or body text or lists of items. When using a word-processor, this may be done automatically (with or without our blessings!) or we may distinguish between headings and body text by using different font sizes, colors, etc.

When creating Web pages, it is possible to impose a structure to the document that is not purely visual. Introducing structure to a document can have beneficial accessibility and usability results for individuals using assistive computer technologies to navigate Web content. For example in the following screenshot, the text content all appears the same and does not contain any structure.

```
Enterprise Level Marketing

Introduction

Enterprise engenderment accelerates initiative platforms, reducing staffing components, accessibility, resulting in bottom line pluralisms, benefit-wise. Incidental re-sizing staff re-accelerated by paradigm shifts and focusing on core suitability and cross-training.

Marketing Review

Marketing teams input produce cross purposing in view of goal alignments due to know workflow education and orientation. Media sourcing as an acquisition strategy is count environment in virtual component methodology. Imaging through ideals rather than real undertaking with negative results. Branding strategies generating motion as activity with ultimately futile effort if left in place.

Analysis of Funding

Analysis of funding is inappropriate in this effort as assets are repurposed in statements
Using Composer, it is possible to impose some structure to the document in order to separate the heading information from the various paragraphs.

1. Move the cursor to the text information you wish to identify as a heading.

2. Select **Format** from the menu bar and select **Paragraph**.

3. Choose the appropriate heading option (e.g., Heading 1, Heading 2, etc.) or select **Paragraph** to identify the text passage as a paragraph.

4. The text formatting may change. The presentation of the text size, color, and font style can be manipulated from under **Format** on the menu bar.

**NOTE** – it is highly recommended to keep the same formatting for the same structure elements (i.e., all the Heading 1's look the same, etc.) throughout your Web pages. This can be controlled using the **Format** menu or by using Cascading Style Sheets.

Referring back to the previous example, the text information "Enterprise Level Marketing" that looked like regular body text in the previous example is now a larger font size with a small change in spacing around the text. Once again, the "presentation" of this information can be manipulated from the **Format** menu or by using Cascading Style Sheets.

While this has resulted in a visual change, there is now also a structural change within the HTML code. This change now allows certain assistive technologies (specifically screen-readers) to navigate through the Web page using the keyboard. Incorporating this type of structure into a Web page provides a greater degree of accessibility and usability for many users.
Defining Lists

Similar to adding headings or identifying body text, another method for adding structure to a Web page is to specify content that is to be a list. Lists can be either bulleted (called "unordered") or numbered (called "ordered"). Actually, an "ordered" list can contain a sequence of either letters or numbers.

Defining a list provides additional structure to a Web page and communicates to screen-reader users the presence of a list as well as the number of items within the list. Individuals who are blind or low-vision can then understand the context of the information being described from the Web page.
To define a list within a Web page:
1. Select the content you wish to specify as a list of items.

2. Select **Format** from the menu bar and choose **List**. Select the type of list that you wish to define (either Bulleted or Numbered). In this example, we will choose Numbered.
The result will be a Web page that has the correct list structure and contain either bullets or numbers for each item.

**To control the "look" of the list:**
1. Set the cursor anywhere within the list of items.
2. Select **Format** from the menu bar and choose **List**.
3. Select **List Properties** to manipulate how the list of items will be presented on the Web page.

![List Properties](image)

**Inserting Images**

Using Composer, you can insert images into your Web document as well as include the necessary accessibility information. Assistive computer technology relies on the "alternate text" attribute of an image to communicate the meaning/purpose of the image. This alternative text is provided by the Web author. Depending on the type of image you insert into your Web document, you will need to specify the type of alternate text appropriate for the image.

When providing alternative text for images try the following:
- Keep the alternative text brief, but be descriptive
- If there is text content in the image, include that information in the alternate text box
- Do not use the word "image" to begin your description – instead identify the type of image being used (photograph, painting, screenshot, etc.)
If the image is very detailed and cannot be summarized in a few sentences, consider placing additional information about the image into the page text preceding or following the image.

More information about alternative text is available at:
http://jimthatcher.com/webcourse2.htm

http://www.webaim.org/techniques/images/

To insert an image using Composer:

1. Place your cursor at the appropriate location to insert an image and choose Image from the menu bar.

2. Select Choose File… to select the image file you wish to use on your Web page.

3. If the image is pertinent to the information on your Web page, select the radio button marked Alternate Text and enter a description of the image.

4. If the image you are using does not convey any meaningful information (i.e., it is just "eye-candy"), it is appropriate to use the Don't use alternate text radio button. (For Advanced Developers: This will include the code alt="")
Creating Data Tables

Composer can also be used to create data tables for the visual display of information. Data tables are valuable to show relationships between various pieces of information.

To insert a table:

1. Determine the number of rows and columns you will need for your table.

2. Select **Table** from the menu bar and choose **Insert > Table**.

3. Enter the number of rows and columns for your table. You can also determine the Width of your table (it is recommended to use percentages instead of pixels for specifying table width). Select **OK** to complete the process.

When creating data tables, it is important to specify certain pieces of information within the table. Specifically, it is necessary to identify the column and row heading information as well as provide a summary of the table itself. By specifying these pieces of information, it is possible for assistive computer technology to communicate the important components of the table to the individual.
Consider the following table.

**Schedule of Classes for Ima Student:**

<table>
<thead>
<tr>
<th></th>
<th>Monday</th>
<th>Wednesday</th>
<th>Friday</th>
</tr>
</thead>
<tbody>
<tr>
<td>English</td>
<td>10AM - 11:30AM</td>
<td>12PM - 1:15PM</td>
<td>3:30PM - 4:00PM</td>
</tr>
<tr>
<td>History</td>
<td>8:30AM - 9:30AM</td>
<td>8:30AM - 9:30AM</td>
<td>8:30AM - 9:30AM</td>
</tr>
<tr>
<td>Math</td>
<td>12:00PM - 1:00PM</td>
<td>No Class</td>
<td>12:00PM - 1:00PM</td>
</tr>
</tbody>
</table>

In this table, the column headers consist of the days of the week (i.e., Monday, Wednesday, Friday) and the row headers consist of the classes for the student (i.e., English, History, Math). It is necessary to include additional structure to this data table in order for assistive computer technologies to function properly and communicate the correct information to the individual.

**Specify the headers:**

1. Highlight the appropriate cells (e.g., Monday, Wednesday, and Friday). Choose **Table** from the menu bar and select **Table Properties**.

2. Select the **Cells** tab. Check the checkbox marked **Cell Style** and from the drop down menu select **Headers**.

3. Select **Apply** and then select **OK**.

Perform the same process for the row headers (i.e., English, History, Math).
Your column and row headers will now appear **bold** and may (or may not) be centered. You can control the appearance of the information, but it is important that the cells are identified as headers.

**Schedule of Classes for Ima Student:**

<table>
<thead>
<tr>
<th></th>
<th>Monday</th>
<th>Wednesday</th>
<th>Friday</th>
</tr>
</thead>
<tbody>
<tr>
<td>English</td>
<td>10AM - 11:30AM</td>
<td>12PM - 1:15PM</td>
<td>3:30PM - 4:00PM</td>
</tr>
<tr>
<td>History</td>
<td>8:30AM - 9:30AM</td>
<td>8:30AM - 9:30AM</td>
<td>8:30AM - 9:30AM</td>
</tr>
<tr>
<td>Math</td>
<td>12:00PM - 1:00PM</td>
<td>No Class</td>
<td>12:00PM - 1:00PM</td>
</tr>
</tbody>
</table>

**Using the "Scope" Method:**
In addition to identifying the headers, it is also necessary to use the "scope" attribute to specify the row and column headers.

1. Move the cursor to the appropriate header cell and select **Table** from the menu bar. Choose **Table Properties**.
2. Under the **Cells** tab, select the **Advanced Edit** button in the lower right portion of the window.

3. In the drop down box under **Attribute**, select "scope". In the drop down box under **Value**, select "col". "Col" is selected as this is the column header.

4. Select **OK** to return to the Table Properties window. Select **Apply** and then **OK** to complete the process for this cell.

5. Repeat for the remainder of the column headers in the table.

Repeat the process for the row headers. Instead of choosing "col" for the value, it is necessary to choose "row" for the row headers.

**Adding the "Summary" Attribute**

The "summary" attribute provides an additional method for describing a data table. Think of the "summary" attribute as an alternative text description for the table. The "summary" attribute should be brief and provide a general description of the relationships among the cells. It is not necessary to include any of the table data, rather the table summary should be a description of what the information is providing.

Including a "summary" attribute will not alter the appearance of the data table, but will increase the accessibility and usability of the table with assistive computer technologies.
In the above example, the data table provided an overview of the class times for "Ima Student". This information may be specific for a specific semester or for the entire year. A summary of the table could include:

"Table of classes and class times for Ima Student for Winter Quarter."

1. Select the table in Composer.

2. Choose Table from the menu bar and select Table Properties. Choose the Table tab.

3. Under the Table tab, select the Advanced Edit button in the lower right portion of the window.

4. In the drop down box under Attribute, select "summary". Enter the table summary in the Value text box.

5. Select OK to return to the Table Properties window. Select Apply and then OK to complete the process for this table.
Web Resources

Downloads
Mozilla Internet Application Suite (includes Composer)
http://www.mozilla.org/products/mozilla1.x/

Netscape Internet Application Suite (includes Composer)
http://channels.netscape.com/ns/browsers/default.jsp

Web Accessibility Information
Jim Thatcher – Accessibility Consulting
http://jimthatcher.com

WebAIM
http://www.webaim.org

WebAIM Training Event Resource
(hosted for the CA Community Colleges)
http://www.htctu.net/divisions/webaccess/webaim/eventdesc.htm

LIFT Text Transcoder
http://www.htctu.net/divisions/webaccess/transcoder/transcodermain.htm

US Section 508 Standards for Web Internet/Intranet Information and Applications
http://www.access-board.gov/sec508/guide/1194.22.htm