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MAGpie (ver. 2.x)

Publisher
CPB/WGBH National Center for Accessible Media (NCAM)

125 Western Avenue

Boston, MA 02134

Phone: 617.300.3400
http://ncam.wgbh.org/index.html

Retail Cost
Free Download from WGBH/NCAM website (see above)

System Requirements
A PC-based computer running Windows 95/98/2000/XP or Apple Ma-
cintosh G3/G4 computer running OSX 10.2 or greater.  You must have 
QuickTime version 5/6 or higher installed in order to caption video con-
tent in MAGpie 2.x.  A free version of the QuickTime player is avail-
able at: http://www.apple.com/quicktime/download/

JAVA (JRE) must be installed in order to install and run the MAGpie 
2.x application.  Installation of the JAVA run-time environment is not 
necessary with the OSX 10.2 operating system from Apple.

The Oratrix GRiNS media player.  This will provide the capability to 
caption RealMedia media clips.

RealOne from Real Networks. You can download a free version of the 
RealPlayer from http://www.real.com .  If you would like to have the 
capability to caption any media file format, it is recommended to up-
grade to the paid version of the RealOne Player.

WinZip, or another unzip utility.  This is required to open the MAGpie 
software download or access the multimedia clips provided by WGBH/
NCAM.  You can down download a shareware version of WinZip from: 
http://www.winzip.com
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Description
MAGpie is a JAVA-based editor for the creation of captions and subtitles for 
digital multimedia.  Using MAGpie, you can author captions and subtitles for 
playback with three playback engines: Windows Media Object using SAMI (Syn-
chronized Accessible Multimedia Interchange) format, Apple’s QuickTime Player 
using QTtext or SMIL (Synchronized Multimedia Integration Language format), 
and RealNetwork’s RealOne Player using SMIL.  MAGpie also has the capability 
to synchronize audio descriptions to follow with the media presentation.

Creating a Project
The following instructions will assist you in creating a captioned multimedia clip 
that can be then exported based on your system requirements.

Select File and New Project.

Identify the location of the media clip in the Base Media location.  In 
the Author Info location, identify the author of the project (optional).

For the Media Toolkit, select the Apple QuickTime Player or the Oratrix 
GRiNS Player depending on the file format of the video presentation.  
MAGpie 2.x now supports the direct captioning of QuickTime and Real 
Media formatted media clips.  Important:  In order to caption Windows 
Media files, you will need to use the Oratrix GRiNS Player AND have 
purchased the full version of the Real One Player.

Select the formatting choices appropriate for your needs.  Caption 
Styles will affect the presentation of content in the caption region, 
whereas Speaker Styles will affect the presentation of information in the 
speaker region.  The speaker region will appear one line above the cap-
tion region.  (It is also permissible to identify the speaker in the caption 
region if there is a desire to save space during the presentation of the 
captioned dialogue).

Identify the Video Width and Video Height from a video editing pro-
gram.  Set the Caption Width at the same value as the Video Width.  It is 
recommended to set the Caption Height at approximately 80 pixels.

Entering Text

MAGpie allows the user to create captions from the media clip audio track within 
the MAGpie interface.  The media clip is controlled from the Player command in 
the menu bar or with the following keyboard commands:

Action Keyboard Command
Play / Pause F6
Stop F7
Insert Start Time from Player F9
Insert End Time from Player F10
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MAGpie contains a Start Time, End Time, Speaker, and Caption column in which 
to enter information to be displayed in the multimedia viewing area.  It is possible 
to directly enter information into the Caption and Speaker text areas based on the 
audio information from the multimedia clip.

Importing Text

MAGpie provides a text importer that allows the user to transcribe text using a 
word-processing document other than the MAGpie interface.  Common word-pro-
cessing programs include MS WordPad, MS Word, Corel WordPerfect, etc.  The 
following steps identify how to import text into the MAGpie interface.

Transcribe the audio component of the multimedia clip into a word-pro-
cessing program.

Insert an extra carriage return between separate blocks of text.

Make sure to insert one extra carriage return after the last line of text in 
your transcribed file.

Save your information as a Text file (with or without line breaks).

Place the cursor in the first cell of the Caption column in the MAGpie 
interface and then select Captions from the menu bar.  Select Insert 
Captions from file… and then select the appropriate text file. Your text 
should import into the MAGpie layout correctly.

Formatting and Editing Captions

Once you have imported the transcribed audio portion of the multimedia clip into 
the MAGpie interface, it may be necessary to format or edit the appearance of the 
captions in the media player.  Under the Style command on the menu bar, the text 
color, font alignment,  font appearance can be manipulated.  It is generally recom-
mended to maintain consistency of the appearance of the captions for the duration 
of the multimedia clip.  If more than one multimedia clip is to be captioned, it is 
also recommended to maintain consistency across different projects so as to not 
visually disturb or surprise the viewer.  More information on captioning guide-
lines can be found under the Captioning Guidelines heading.

To alter text content:

Highlight the text you wish to alter using the mouse or keyboard com-
mands.

Click Style from the menu bar and select the desired attributes (e.g., 
change the font color).

The changes will only appear in the caption cell that you choose.

If you wish to globally change the appearance of the text, you will need 
to go to the File menu and select Properties.  Changes in this dialog box 
will affect the appearance of all the text.
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To edit the caption layout:

Select the text that you would like to change.

Click Edit from the menu bar and select the desired function.  From this 
menu, you can insert, delete, or copy “events” to different times within 
the caption sequence.

Alternatively, you may use the formatting tool bar that is positioned 
directly above the “Caption” and “Speaker” columns.  Changes at this 
level will only affect specific cells in the presentation and not the over-
all text content.

Synchronizing Video and Captioned Dialogue

Transcribing the captioned dialogue of the multimedia clip is generally the longest 
and most tedious part of the captioning process.  Once the text has been entered 
into the Caption column and broken into manageable “chunks”, it is necessary to 
synchronize the transcribed dialogue with the on-screen dialogue.  While it is pos-
sible to manually enter the video time code under the Timecode column heading, 
the following procedure provides a faster and more efficient method.

To synchronize the video to the captioned dialogue:

Position the cursor in the first cell under the Timecode column heading.

Position the multimedia clip you wish to caption at the beginning of the 
presentation.

Press F6 key to start the multimedia clip.

When you hear the initial words of the first caption, press the F9 key.  
This will “capture” the timecode of multimedia clip and insert this time-
code under the Start Time column heading.

With the multimedia clip still playing, press the F9 key when it is time 
for the next block of captioned text to appear in the multimedia clip.

Important Note:

Once you have completed the synchronization process, make sure to save your 
project.  To save your project, select Save As from the File menu.

Selecting the Appropriate Output
Once the process of synchronizing the captioned dialogue and video clip is com-
plete, it is necessary to export the captioned information to the desired format.  
MAGpie offers the capacity to export into three different formats.
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SAMI (for Windows Media Player)

SAMI – Synchronized Accessible Media Interchange – is Microsoft’s proprietary 
format for providing captioning and audio descriptions for multimedia clips.  The 
one drawback to using the SAMI format is the inability to have multiple concur-
rent streams.  For example, it is possible to have a media file captioned or a media 
file with audio descriptions, but not have a media file with audio descriptions and 
captioned dialogue.

To output to the SAMI format:

Choose Export from the menu bar.

Select Windows Media Player – SAMI Format.  MAGpie will create a 
.smi file that contains the captioned information in the same directory as 
the saved project file.

Proceed to the Accessible Multimedia in Web Pages section for infor-
mation regarding how to review the captioned media presentation in the 
Windows Media Player.

SMIL (for RealPlayer)

SMIL – Synchronized Multimedia Integration Language – is the format adopted 
by the World Wide Web Consortium (W3C) as a standard for multimedia on the 
Internet.  SMIL allows for the streaming of multiple files, thus providing the 
developer with the flexibility to integrate audio descriptions and captioning into a 
multimedia presentation.  The SMIL standard is supported by RealPlayer via the 
RealText format (.RT extension) using RealPlayer G2 and higher.  If you are not 
satisfied with the output information, make corrections to the captioned informa-
tion and output the content again.

To output to the SMIL format:

Choose Output from the Menu Bar.

Select SMIL via RealText.  This will create a .RT file and a SMIL file 
(the SMIL file “points” to the .RT file).  If there are other elements that 
are to be included in the final multimedia presentation, these elements 
will have to be added to the SMIL file following the work in MAGpie.

Combine all relevant files into the same file folder.

Review the captioned information by opening the .RT file with Real-
Player.
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QuickTime

QuickTime is the proprietary format for Apple and requires additional steps to 
include the captioned information in a multimedia presentation.  Once the cap-
tioned information has been exported, it is necessary to import this information 
into a QuickTime movie format and add this new “movie” to the original multi-
media presentation.  If you are using QuickTime version 5 or later, it is possible to 
provide captions using the SMIL method.

To output to a QuickTime format:

Choose Export from the menu bar.

Select QuickTime – SMIL 1.0 format.  Two files will be exported to the 
directory in which the project is saved.  A en_US.qt.txt file and a .qt.
smil file will be created.

Review the captioned presentation from within the QuickTime player 
(version 5.x and higher).  If any corrections are necessary, make the 
changes within the MAGpie interface and repeat the previous steps.

For information how to deliver the en_US.qt.txt file or the .qt.smil file on Web 
pages, please refer to the section Accessible Multimedia in Web Pages.
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Hi-Caption

Publisher
HiSoftware Incorporated

6 Chenell Drive Suite 280

Concord, NH 03301

USA

Toll-Free: 888-272-2484

Technical Support: 603-229-3055
http://www.hisoftware.com 

Retail Cost
Visit the HiSoftware website for information.  May also be licensed through other 
HiSoftware applications (special pricing available for California Community Col-
leges - contact the HTCTU).

System Requirements
A PC-based computer running Windows 95/98/Me/2000/XP.

Recommended 64 MB RAM or greater.

25 MB of Hard Disk space.  Additional memory necessary for saving 
project sets.

Description
Hi-Caption allows for the creation, editing, and testing of the captioning of your 
Windows Media files.  The captioning file is stored in a SAMI file which is an ac-
ronym for Synchronized Accessible Media Interchange.   Hi-Caption also allows 
for the export of SMIL for Real Player and SMIL/QuickTime text for other media 
types.  Hi-Caption can provide users with an interface to create text transcripts 
while watching videos, or allow for the importation of text content to minimize 
development time.  Media files playable for either the Windows Media Player or 
RealOne Player may be opened from within the Hi-Caption interface.

Hi-Caption for Flash is a separate product that allows for the captioning of Flash 
presentations.  For additional information, please visit:
http://www.hisoftware.com/hmccflash2004/index.html.
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Captioning a Video
Hi-Caption will support media files playable in either the Windows Media Player 
or the RealOne Player.  If your media type is in a different format, please convert 
to a compatible format before continuing.

Videos stored on your computer

Select File from the menu bar, choose Open, and select Media File.  This will 
automatically create a SAMI file with the same name as the base media file name.  
The SAMI file will contain all the text, timecode, and formatting information for 
the captions.

Videos stored on the Web

If the media that you wish to caption is hosted on a webserver, select File from the 
menu bar, choose Open, and select Media File from URL.  Enter the full URL of 
the media file and choose whether or not you wish to create a new SAMI file or 
open a HiSoftware Project file.

Previously created Files

If you wish to open a previously created SAMI file, select File from the menu 
bar, choose Open, and select SAMI File.  This will allow you to open previously 
created SAMI files (created by either Hi-Caption or other SAMI tools).  Only text 
that is associated with a timecode is saved in a SAMI file.  If you are working on 
a longer media presentation and do not have timecode associated with each text 
entry, then refer to the Hi-Caption Project information.

Hi-Caption Projects

You may also open a Hi-Caption Project file from the File menu.  A Hi-Caption 
project file contains all the text that may be relevant to a media presentation.  In 
other words, if you are entering the text content of a media presentation, but have 
not completed the synchronization process, then it is necessary to perform a Save 
as Project.  This will retain all the text information associated with the project and 
not just the text associated with a timecode entry.  If you simply perform a Save 
As, you will lose the text information not associated with a timecode entry.

Entering Captions
You can enter the text information of the audio portion of the media presentation 
directly into the Hi-Caption interface.  This requires you to listen to a few seconds 
of the audio and then enter the correct information into the proper column.

Press the Play button on the video player (or select Play from Player on 
the menu bar) and listen to five to ten seconds of video.

1.
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As soon as you begin to hear spoken information (or audio sounds), 
press the Add SYNC button located in the lower right portion of the ap-
plication.

Pause the video playback and enter in the audio you heard in the Cap-
tion region of the new row.  You may also choose to enter a speaker as 
well (more information on speakers later).

Press Play to continue the video and when you hear additional audio, 
press the Add Current button located in the lower left portion of the 
application.  This will create a new row in which to enter in the text 
information of the audio component.

Continue this process until you have entered all the audio information 
of the media presentation.  If there are any errors, simply select the row 
and press the Delete button.

Importing Text

Hi-Caption provides a text importer that allows the user to transcribe text using 
a word-processing document other than Hi-Caption.  Common word-processing 
programs include MS WordPad, MS Word, Corel WordPerfect, etc.  The follow-
ing steps identify how to import text into the Hi-Caption interface.

Transcribe the audio component of the media presentation into a word-
processing program.  Use a carriage return (i.e., hard-return) to mark the 
end of a line.  You can separate blocks of captioned text with a blank 
line if you desire (this can be ignored during the import process).

Save your information as a Text file (with or without line breaks).

Open Hi-Caption and make sure there is one SYNC row available.  Se-
lect Tools and choose Import Wizard.

After the Import Wizard begins, identify the appropriate text file by 
entering the path or by pressing on the “…” at the right side of the win-
dow.

Select the classes to import the captions into.  This option is if you are 
providing captions for multiple languages/formats.  You should at least 
provide captions for the class “ENUSCC”.

If you have multiple speakers, make sure to leave the “Speaker” column 
blank.  Hi-Caption will not separate speakers at this point – you must do 
this within the main Hi-Caption interface.

Choose the first two checkboxes if you have created the text file using 
the carriage return to separate captions and if you used blank lines to 
separate out the captioned text.  You may also separate captions using 
strings of punctuation (more advanced feature).

Select Finish.  You may need to still clean up the information presented 
in the Hi-Caption matrix.
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Your text should import into the Hi-Caption interface correctly.  After you have 
entered the text information, move to the section titled Synchronizing Video and 
Captioned Dialogue

Formatting and Editing

Once you have imported the transcribed audio portion of the multimedia clip into 
the Hi-Caption interface, it may be necessary to format or edit the appearance of 
the captions in the media player.  It is generally recommended that the individual 
captioning the audio segment maintain consistency of the appearance of the cap-
tions for the duration of the multimedia clip.  If more than one multimedia clip is 
to be captioned, it is also recommended that there is consistency across different 
projects so as to not visually disturb or surprise the viewer.  More information on 
captioning guidelines can be found under the Captioning Guidelines section.

Formatting captions is accomplished by specifying a class in the Hi-Caption 
interface and manipulating information within the specified class.  To manipulate 
the presentation of captions, you will need to load a specific “class” and make the 
necessary changes to the font, font-sizes, and colors.
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To alter font information:

Select Tools from the menu bar and choose HMCC Class File Editor.

Choose the Open button and select the class you wish to alter from the 
various options.  The default is ENUSCC.

Choose the necessary font-family, font-size, and colors that you wish to 
apply to the captioned text.  You may also specify the language type.

You may also choose to save a different class type when working with 
different languages or if you want to present captions with different 
formatting.  Choose Add… to identify a new class and enter the class 
identifier (follow the format specified).

Provide a class name (e.g., Spanish Captions, English Captions, etc.) 
and determine how you want the captions to look.

Save the new class type by selecting the Save button.

Synchronizing the Captions

Transcribing the captioned dialogue of the multimedia clip is generally the longest 
and most tedious part of the captioning process.  Once the text has been entered 
into the Caption column and broken into manageable “chunks”, it is necessary to 
synchronize the transcribed dialogue with the on-screen dialogue.  While it is pos-
sible to manually enter the video time code under the Time Start column heading, 
the following procedure provides a faster and more efficient method.

To synchronize the video to the captioned dialogue:

Position the cursor in the first cell under the Time Start column heading.

Position the multimedia clip you wish to caption at the beginning of the 
presentation.

Press Play to start the multimedia clip.

When you hear the initial words of the first caption, press the F6 key.  
This will “capture” the timecode of multimedia clip and insert this time-
code under the Time Start column heading.

With the multimedia clip still playing, press the F6 key when it is time 
for the next block of captioned text to appear in the multimedia clip.

Continue this process until the synchronization of the audio component 
and the text is complete.
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Exporting the Synchronized Captions
Once the process of synchronizing the captioned dialogue and video clip is com-
plete, it is necessary to export the captioned information to the desired format.  
Hi-Caption by default will create a SAMI file for the Windows Media Player.  You 
can then create a SMIL file for the Real Player or a .SMIL/QuickTime file for the 
QuickTime player.

SAMI (for Windows Media Player)

SAMI – Synchronized Accessible Media Interchange – is Microsoft’s proprietary 
format for providing captioning and audio descriptions for multimedia clips.  The 
one drawback to using the SAMI format is the inability to have multiple concur-
rent streams.  For example, it is possible to have a media file captioned or a media 
file with audio descriptions, but not have a media file with audio descriptions and 
captioned dialogue.

Hi-Caption automatically creates a SAMI file in the same directory as the original 
media presentation.  As you proceed in the captioning process, just remember to 
save and the SAMI file will be updated.

SMIL (for RealPlayer)

SMIL – Synchronized Multimedia Integration Language – is the format adopted 
by the World Wide Web Consortium (W3C) as a standard for multimedia on the 
Internet.  SMIL allows for the streaming of multiple files, thus providing the 
developer with the flexibility to integrate audio descriptions and captioning into a 
multimedia presentation.  The SMIL standard is supported by RealPlayer via the 
RealText format (.RT extension) using RealPlayer G2 and higher.  If you are not 
satisfied with the output information, make corrections to the captioned informa-
tion and output the content again.

Hi-Caption will generate two separate files that you must save in order to view 
captions in the Real Player.  The file extension “.smil” is the root file that contains 
references to the media presentation and the associated captions.  The file exten-
sion “.rt” is the RealText file that contains the timecodes and caption information.  
To review your completed work, open the “.smil” file with Real Player.

To output to the SMIL format:

Choose the SMIL (RealText) tab at the bottom of the application.

In the top window, select Refresh… to create SMIL code from SAMI 
code.

This will open a dialog window to create the SMIL code.  Refer to the 
SMIL Specification options on Page 12 for the parameters.
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Once you have entered the necessary SMIL parameters, you should see 
SMIL code in the upper pane.  In the lower pane, press the Refresh… 
button to generate the RealText information.  You will be prompted to 
select a SAMI class – choose the class ENUSCC (or another class you 
created in the Hi-Caption application).

Make sure to save both the upper and lower files by selecting the ap-
propriate Save File… button.  If you wish to make changes to layout, 
etc. in the upper pane, you do not need to re-save the information in the 
lower pane.

SMIL Specification Options

Converting SAMI code to the SMIL specification will require you to include ad-
ditional elements necessary for the video and textregion layout.  In part, this is 
dependent on the size of the video and the caption region that you wish to provide 
to the user.  When converting from SAMI to SMIL, Hi-Caption will ask you to in-
put the desired dimensions (in pixels) of the video region and the caption region.  
Obviously, the video region will be set by the size of the video presentation, but 
there is some flexibility with the caption region.

Generally, the convention is to set the width of the caption area to be the same 
as the width of the video area.  Specify a height that is larger than might seem 
necessary. For a set of captions with a maximum of three 14-point lines, a height 
of 75 pixels seems to work well.  Differences in the way Windows and Macintosh 
computers display fonts may create obstacles to the creation of a cross-platform 
caption display.

Enter the following Information:

Media Object Element - choose video from the drop down list.

Src Attribute Value - this should automatically enter the name of the 
media file.

Region Attribute Value - enter the value videoregion.

Region ID - the top cell should contain the value videoregion and the 
lower cell should contain the value textregion.  Enter background color 
for both the video and text region.

Text Region measurements - for top, choose a value approximately 
10-15 pixels greater than the height of the video.  For height, choose 
a value between 75-90 pixels.  For width, choose a value equal to the 
width of the video.  You do not need to enter information regarding the 
videoregion if you wish to accept the default values.
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QuickTime

QuickTime is the proprietary format for Apple and requires additional steps to 
include to the captioned information in a multimedia presentation.  Once the cap-
tioned information has been exported, it is necessary to import this information 
into a QuickTime movie format and add this new “movie” to the original multi-
media presentation.

Hi-Caption will generate two separate files that you must save in order to view 
captions in the QuickTime Player.  The file extension “.qt.smil” is the root file that 
contains references to the media presentation and the associated captions.  The file 
extension “.qt.txt” is the QuickTime Text file that contains the timecodes and cap-
tion information.  To review your completed work, open the “.qt.smil” file with 
QuickTime.

Important Note:

You can change the values of any of the information contained within the Quick-
Time/SMIL files by opening the files in a text-editor.

To output to the QuickTime/SMIL format:

Choose Tools from the menu bar and select QuickTime Text… .

You will be presented with the “Create QuickTime Text from SAMI” 
window.  In the top window, select Refresh… to create SMIL code from 
SAMI code.

This will open a dialog window to create the SMIL code.  Refer to the 
SMIL Specification options on Page 15 for the parameters.

Once you have entered the necessary SMIL parameters, you should see 
SMIL code in the upper pane.  In the lower pane, press the Refresh… 
button to generate the QuickTime Text information.  You will be 
prompted to choose the QuickTime Text Properties.

For the QuickTime Text Properties, choose the appropriate SAMI class 
that you are using in the presentation.  You can leave the default settings 
for font sizes as these tend to work best (i.e., font-style: Arial, Speaker 
font-size: 12, Caption font-size 16).  In the QuickTime Text Window 
Size and Color, choose a Black background and White Text.  Set the 
Window Height and Window Width to the same values as identified in 
the SMIL dialog window.

Make sure to save both the upper and lower files by selecting the appro-
priate Save As… button.  If you wish to make changes to layout, etc. in 
the upper pane, you do not need to re-save the information in the lower 
pane.
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QuickTime/SMIL Specification Options

Converting SAMI code to the QuickTime/SMIL specification will require you to 
include additional elements necessary for the video and textregion layout.  In part, 
this is dependent on the size of the video and the caption region that you wish to 
provide to the user.  When converting from SAMI to SMIL, Hi-Caption will ask 
you to input the desired dimensions (in pixels) of the video region and the caption 
region.  Obviously, the video region will be set by the size of the video presenta-
tion, but there is some flexibility with the caption region.

Generally, the convention is to set the width of the caption area to be the same as 
the width of the video area.  Specify a height that is larger than might seem neces-
sary. For a set of captions with a maximum of three 14-point lines, a height of 
75-90 pixels seems to work well.  Differences in the way Windows and Macintosh 
computers display fonts may create obstacles to the creation of a cross-platform 
caption display.

Enter the following Information:

Media Object Element - choose video from the drop down list.

Src Attribute Value - this should automatically enter the name of the 
media file.

Region Attribute Value - enter the value videoregion.

Region ID - the top cell should contain the value videoregion and the 
lower cell should contain the value textregion.  Enter background color 
for both the video and text region.

Text Region measurements - for top, choose a value approximately 
10-15 pixels greater than the height of the video.  For height, choose 
a value between 75-90 pixels.  For width, choose a value equal to the 
width of the video.  You do not need to enter information regarding the 
videoregion if you wish to accept the default values.
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Macaw

Publisher
Whit Anderson
http://www.whitanderson.com/macaw/

System Requirements
Apple OS 9 or Apple OS X 10.2 and above OR MS Windows 2000/XP

QuickTime (QuickTime Pro necessary to create captioned QT movie)

Description
Macaw is an easy to use captioning tool designed for use with the QuickTime me-
dia format.  Macaw allows users to create or import a transcript into the Macaw 
interface and then synchronize the transcript with the audio track of the Quick-
Time movie.  Once the text content has been synchronized with the multimedia 
presentation, Macaw creates a new “text” movie that can be then overlaid upon 
the uncaptioned multimedia presentation.  Macaw provides several additional 
utilities, such as the Macaw Track Manager and Toggle Buttons, that streamline 
the production and presentation of captioned QuickTime media.

Macaw is different from other captioning tools in that creates a text track that is 
then imported into QuickTime Pro to create the “text” movie.  Other captioning 
tools (e.g., MAGpie or Hi-Caption) can export synchronized transcripts as Quick-
Time compatible SMIL files as well as handle multiple media formats.  Instead of 
a “multiple-in/multiple-out” captioning tool, Macaw is designed to support cap-
tioning for QuickTime media for both Apple and PC systems.

Getting Started
To use Macaw to caption a QuickTime video, it is necessary to have the movie 
and transcript set properly in order to streamline the production process.

Setting up the QuickTime video

Set the QuickTime video to 320x240 to fit within the Macaw captioning interface.  
If the video is larger than 320x240, try setting the video to appear as “Half-Size” 
(requires QuickTime Pro).

Setting up the text transcript

The transcript should be a text-only file (ASCII) as created from Notepad, TextE-
dit, etc. or saved from a word processing program as “Text-only”.  Create the tran-
script such that there is a blank line between the text phrases.

1.
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Example of single-line transcript:

We begin the process,

in today’s demonstration,

by scanning the documents

on the Xerox DocuCenter 320.

If you wish to combine several lines together, place a hard-return at the end of 
the phrase where you wish to split the sentence.  In the example below, the first 
two lines would appear at the same time in the captioned video, followed by the 
second two lines of text.

Example of double-line transcript:

We begin the process,

in today’s demonstration,

by scanning the documents

on the Xerox DocuCenter 320.

Important Note:

For 320 x 240 screen resolution, two lines of text and approximately 20 charac-
ters per line (4-6 words) seems to present well.  For 640 x 480 screen resolutions, 
two-lines of text and approximately 29 characters per line (6-8 words) seems to 
persent well.

Setting the Text Style

Macaw will allow you to set some basic text formatting parameters for the cap-
tioned movie.  After you have selected the video and text transcript and BEFORE 
you caption the movie, you can set the text style options.  Press the Make Style 
Choices button in the Macaw interface to access the text style options.

Within the style options screen, several of the options you can change are the:

Text style – plain, bold, italic

Justification – left, center, right

Text size – 8 pt. to 24 pt.

•

•

•
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Font – Arial, Helvetica, Times

Caption Height – 12 pt. to 64 pt.

There are several additional preset values.  To create captioned videos for comput-
er or iPod viewing, videos at 320 x 240 screen-resolution and with the transcript 
arranged in the two-line format (with 4-6 words per line), then the following 
parameters should be sufficient:

Justification:  Center

Type Size:  18 pt.

Type Style:  Plain

Font:  Arial

White Text on Black Background

Caption Height: 48 pt.

Caption Width: 320

Time Scale: 30

For those who are comfortable editing the QT Text file, it is possible to custom-
ize the Type Size and Caption Height values to something other than the preset 
Macaw values.

Synchronizing the Transcript and Movie
Once you have the QuickTime movie and the text transcript prepared, Macaw can 
import these assets and begin the process of synchronizing the transcript with the 
QuickTime movie.  While the movie is playing, you will synchronize the appear-
ance of the text information with the audio dialogue of the movie.  Remember to 
change the text style options before you begin the captioning process.

Important Note:

Pressing Quit in any of the Macaw screen interfaces will cause the program to 
close.

To add a timestamp:

Open the Macaw interface and choose the movie and text transcript.

Press the Play button in the QuickTime movie interface to begin the 
movie.

Press the Mark Sync button (or “m” on the keyboard) to synchronize the 
screen text with the spoken dialogue.  If you need to pause the movie, 
press the Pause button in the QuickTime movie interface.

Once the movie has been synchronized, press the “Save the Text Track 
to a File” button.  This saves the text transcript with embedded time 
code.  The default file name will be “track.txt”.

•

•

•

•

•

•

•

•

•

•
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Adding Captions to the Original Movie

After developing the synchronized text transcript, you must convert this file into a 
QuickTime movie.

Begin QuickTime Pro.  Choose File > Open File and navigate to the 
“track.txt” file of your movie.  (Hint: you may need to set the “Files of 
type:” selection to All Files).

The “track.txt” file will open in a QuickTime player.  Choose Edit > 
Select All and then choose Edit > Copy.

Open the original (uncaptioned movie) in QuickTime Pro.  Ensure that 
playback head is at the start of the video.  Choose Edit > Add to Movie 
to insert the copied text movie.

The added text movie may be added to the top of the uncaptioned movie 
in the QuickTime player interface.  Once the text track movie is added 
to the original movie, you can move the text track around the Quick-
Time interface and position the necessary elements.

Choose Window > Show Movie Properties in QuickTime Pro to open 
the movie properties window.  You should have a Sound Track, Video 
Track, and Text Track visible in the top portion of the interface.

Select Text Track and choose the “Visual Settings” tab in the lower por-
tion of the window.

In the “Offset” edit boxes, enter in the total height of the movie in the 
second box (this is the vertical offset).  This tells the text movie clip to 
“move down” the specified number of pixels.  Ideally, the text movie 
clip should reside just beneath the uncaptioned movie.

Close the Movie Properties window to return to the original movie 
interface.  Your movie captions should now appear under the original 
movie.  Play back the movie to verify the captions display correctly in 
the lower region.

Save the newly captioned movie as a Self-Contained movie (File > Save 
As…).  It is recommended to use a slightly different file name (e.g, my-
movie_cap.mov) to distinguish between the captioned version and the 
uncaptioned version.

Important Note:

If you do not know the height of the movie, you can determine the uncaptioned 
movie height by selecting the Video Track in the Movie Properties window and 
then the Visual Settings.  The movie dimensions will be listed in the Transforma-
tion region.  Alternatively, you can select the QuickTime player of the uncap-
tioned video and choose Window > Show Movie Info for the height and width of 
the uncaptioned movie.
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Adding Caption Toggle to QuickTime movies
In some cases, it may be beneficial to allow users to be able to toggle the captions 
on or off from within the QuickTime player.  You can add this toggle function by 
first downloading the caption toggle sprite from http://www.whitanderson.com/
macaw/toggle/toggle.htm .  You will need to unzip/extract the actual toggle movie 
from the downloaded file.  This is (essentially) a simple QuickTime movie that 
you can position within your captioned movie to enable or disable the appearance 
of the captions.

Open your captioned movie presentation in QuickTime Pro and the 
“toggle_caption.mov” file from the website.

In “toggle_caption.mov”, choose Edit > Select All and then choose Edit 
> Copy.

In the captioned movie file, choose Edit > Add to Selection and Scale.

Open the Movie Properties in your captioned movie (Window > Show 
Movie Properties).  Change the name of the Text Track to “caption”.  
Position the “toggle_caption” track using the Visual Settings tab (the 
lower left-corner of the player is generally appropriate).

Close the Movie Properties window and click on the “CC” button in 
your movie.  This should show or hide the caption region of the movie.  
Remember to save your movie.
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Windows Media Captioning

The section assumes you have already created a SAMI file complete with time-
stamped captions using an application like MAGpie, Hi-Caption, or another pro-
gram.  If you have not already created your captioned SAMI file, please review 
the MAGpie or Hi-Caption sections for captioning a Windows Media file.

To place multimedia content in web pages, a web page designer can embed the 
multimedia clip into the page itself or allow the multimedia clip to open a player 
on the user’s computer.  For accessibility purposes, it is generally recommended 
to allow the specified media player (i.e., QuickTime, Windows Media Player, 
or Real Player) to open on the user’s computer.  A media player that opens on 
the user’s computer provides full access (including keyboard commands) to the 
positioning elements that control the rate of play of the multimedia clip.  This 
provides the user with greater flexibility when operating the media player and 
controlling the rate of presentation.

SAMI Code

The Uniform Resource Locator (URL) link used in SAMI specifies a path to the 
location of the SAMI file and Windows Media file. The special URL link associ-
ates a Windows Media file to the appropriate SAMI file.

Example syntax for a SAMI URL:

full location path of the media file?sami=full location path of the SAMI file

The SAMI URL syntax is commonly used in a hyperlink or a Windows Media 
metafile. However, newer versions of the Windows Media Player may not always 
display the captions correctly if simply linking to the multimedia presentation. 
Therefore, it is recommended that you create an .ASX file, which contains the 
filename path to both the video presentation and the captioned presentation (i.e., 
SAMI file). This will allow the captions to be viewed in all versions of the Win-
dows Media Player.  The following is the recommended method to deliver cap-
tions using the Windows Media Player.

Step 1 - Create the .ASX file
The first step is to create a .ASX file. If you are using Windows streaming media, 
it is better to create a .ASX file to deliver your Windows streaming media for se-
curity reasons. The .ASX file can be created in a text editor (such as Notepad) and 
saved with the .ASX extension.
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Example of a .ASX file:

<asx version=”3.0”>

<abstract>Place information describing the show here</abstract>

<title>Title of the show goes here</title> 

<author>Author Name</author>

<copyright>Place (c) copyright info here</copyright>

<entry>

<ref href=”http://servername/filename.wmv?SAMI=http://servername/filename.
smi” />

<abstract>Place information describing the clip here</abstract>

<title>Title of the clip goes here</title> 

<author>Your Name or the Author of the Clip</author>

<copyright>Place (c) copyright info here</copyright>

</entry>

</asx>

Step 2 - Modifying the .ASX file
Once you have created a .ASX file (you can copy and paste the above information 
into a text editor), you will need to slightly modify the .ASX file. In the .ASX file, 
it is necessary to identify the <ref href=”...”> tag. This is where you place the full 
URL of the location of the Windows media file and the full URL of the location of 
the SAMI file. Notice that there is the text ?SAMI= between the two URL’s. This 
is necessary to properly deliver the SAMI file to the Windows Media Player and 
ensure the captions playback correctly.

Step 3 - Delivering the Content via the Web
After you have made the appropriate URL path corrections to the .ASX file, you 
will need to create a hyperlink from your web page to the .ASX file. 

Save your .ASX file to your webserver.

Create your webpage.

Create a hyperlink that links to the .ASX file on the webserver.  When 
a visitor clicks the web page hyperlink, this will activate the .ASX file, 
which in turn will begin both the video clip file and the captioned file 
(see diagram below).

The result will be a captioned video presentation that appears on the visitor’s 
computer.  Check your presentation to make sure it appears correctly in the Win-
dows Media Player.

1.

2.

�.



Captioning Web-based Media

25

If the captions do not appear in the media player (and you have checked that the 
path to the media files is correct) you may need to turn on the captions in the Win-
dows Media Player.  Please see the section titled Playing the Media Clip with 
Captions for more information.
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RealPlayer Captioning

The section assumes you have already created a SMIL file complete with time-
stamped captions using an application like MAGpie, Hi-Caption, or another pro-
gram.  If you have not already created your captioned SMIL file, please review the 
MAGpie or Hi-Caption sections for captioning a RealMedia presentation.

Similar to the process undertaken with Windows Media Player media, it is nec-
essary to complete additional tasks in order to open a client-side version of the 
RealPlayer media interface.  If you are using a RealNetworks streaming server, it 
will be necessary to coordinate with your network/computer technology adminis-
trator in order to place media files in the proper server location.  Specifically, you 
will need to know if Ramgen is enabled, and the correct procedure for upload-
ing streaming media content to the streaming server.  When Ramgen is enabled, 
it acts to launch the RealPlayer on the client’s computer and provide direction to 
the .SMIL file located on the streaming server.  The .SMIL file will then point to 
the relevant files necessary for the streaming media presentation.  Your hyperlink 
code should look similar to the following when using a RealNetworks streaming 
server with Ramgen enabled.

Example hyperlink code for RealPlayer:

<a href=”http://realserver.company.com:8080/ramgen/sample.smil”>...</a>

If you are not using a RealNetworks streaming server with Ramgen enabled, it 
will be necessary to create a .ram file manually.  Similar to using the Ramgen 
function, a .ram file resides on the server and will contain the correct path to the 
.smil file.  This in turn tells the RealPlayer what content to present to the user.

Step 1 - Creating a .RAM file manually
If using a RealNetworks streaming server with Ramgen disabled, enter the full 
network path to the appropriate SMIL file using a text editor (e.g., Notepad)

Ramgen disabled example:

rtsp://realserver.company.com/media/sample1.smil

If using a Web server for playback for the streaming media clip, specify the Web 
server name and the location of the SMIL file on the server using a text editor 
(e.g., Notepad).

Webserver example:

http://www.company.com/media/sample1.smil
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For local playback (file located on the computer), specify the location of the clips 
relative to the location of the .RAM file on the computer using a text editor (e.g., 
Notepad).

Local playback example:

file://media/sample1.smil

Create the appropriate .RAM file depending on the hardware configuration intend-
ed for the presentation. When you have entered the necessary information, save 
the file with a .ram extension.

Step 2 - Delivering Content via the Web

Once you have created a .ram file that specifies the location of your SMIL file, 
you are ready to present your project on the web.  Move the .ram file to the Real-
Networks or Web server as well as the content you intend to stream. The multime-
dia clip(s) and SMIL file do not need to reside on the same server as the .ram file. 
The .ram file will point to the specified multimedia clips and present this content 
to the user’s player.

Create your webpage.

Create a hyperlink to the .ram file. This should be similar to the follow-
ing <a href=”http://www.yourwebaddress.com/media/clip1.ram”>Video 
Link </a>.

When a visitor clicks the web page hyperlink, this will activate the .ram 
file, which in turn will begin both the video clip and the .rt file (i.e. cap-
tioned dialogue file).  The result will be a captioned video presentation 
that appears on the web page visitor’s computer.

Check your presentation to make sure it appears correctly in RealPlayer.

If the captions do not appear in the media player (and you have checked that the 
path to the media files is correct) you may need to turn on the captions in the 
RealOne Player.  Please see the section titled Playing the Media Clip with Cap-
tions for more information about how to make the captions appear in your media 
player.
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QuickTime Captioning

The section assumes you have already created a QT Text or QT SMIL file com-
plete with time-stamped captions using an application like MAGpie, Hi-Caption, 
Macaw, or another program.  If you have not already created your captioned 
file, please review the MAGpie, Hi-Caption, or Macaw sections for captioning a 
QuickTime presentation.

Captioning QuickTime movies can be accomplished using several different 
method.  This manual identifies the procedures for two methods of presenting cap-
tioned QuickTime movies: using a QT Text track to embed captions in a movie or 
using QuickTime and SMIL to display the captions (not embed) in the QuickTime 
player.

QuickTime and SMIL
QuickTime versions 4.1 and later have the capability of recognizing the SMIL 
format for video presentations.  When using the SMIL format to display captions, 
your computer system may attempt to begin the presentation with a media player 
other than QuickTime. When viewing a presentation on your local system, it may 
be necessary to open QuickTime first and then open the SMIL file from within the 
QuickTime Player.  For a complete description of the QuickTime elements that 
can be controlled using the SMIL format, visit:
http://developer.apple.com/techpubs/quicktime/qtdevdocs/

Step 1 - Create QuickTime SMIL file

Create a captioned presentation using MAGpie 2.01.

Export the captioned file as “QuickTime - 1.0 SMIL format”.

Two files will be exported.  One file will end with “.qt.smil” and the 
second file will end with “.qt.txt”.

Check the “.qt.smil” file to make sure the video source and textstream 
source reference the correct files.  The video source should be the .mov 
file (i.e., the video file) and the textstream should be the .en_US.qt.txt 
file.

1.

2.

�.

4.



Captioning Web-based Media

29

Example SMIL file:

<?xml version=”1.0” encoding=”UTF-8”?>

<smil xmlns:qt=”http://www.apple.com/quicktime/resources/smilextensions”

xmlns=”http://www.w3.org/TR/REC-smil” qt:time-slider=”true”>

<head>

<meta name=”title” content=””/>

<meta name=”author” content=”Sean Keegan”/>

<meta name=”copyright” content=””/>

<layout>

<root-layout height=”335” width=”330” background-color=”black”/>

<region height=”240” width=”320” background-color=”black” left=”5” top=”5” 
id=”videoregion”/> 

<region height=”80” width=”320” background-color=”black” left=”5” top=”245” 
id=”textregion”/>

</layout>

</head>

<body>

<par dur=”0:01:25.87”>

<video dur=”0:01:25.87” region=”videoregion” src=”http://servername/filename.
mov”/>

<textstream dur=”0:01:25.87” region=”textregion” src=”http://servername/file-
name.en_US.qt.txt”/>

</par>

</body>

</smil>

Step 2 - Delivering Content via the Web

Once you have a SMIL file that references your QuickTime movie and the Quick-
Time text track, it will need to be posted on your web page. There are several 
methods for posting a QuickTime/SMIL presentation on a Web page.  An easy 
method for presenting the QuickTime/SMIL content is by creating a QuickTime 
link.  This involves using a .qtl file, which is essentially a XML file, that links 
directly to the SMIL file.  The SMIL file in turn begins the QuickTime movie and 
captions in the newly opened QuickTime player.
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QuickTime hyperlink code example:

<?xml version=”1.0”?>

<?quicktime type=”application/x-quicktime-media-link”? >

<embed src=”http://www.collegename.edu/the_smil_file.smil”  
autoplay=”false” />

The above code can be edited in any text editor.  Change the “src” information to 
reflect your appropriate college information and save the above code as a “.qtl” 
file (you may need to add the .qtl MIME type to your server).  When authoring 
your Web page, create a hyperlink directed at this “.qtl” file.  QuickTime will 
automatically open on the user’s computer with the video loaded.

QuickTime Text Track
A QT Text track is a text file that contains time-stamped information readable by 
the QuickTime player.  Using QuickTime Pro, a QT Text track will create a movie 
that plays back the captioned text.  This captioned text movie can then be overlaid 
upon the original movie such that the playback of original movie is synchronized 
with the presentation of the captioned movie.  

Using MAGpie or Macaw, first create a QT Text file of the original movie.  Please 
review the previous sections (or the Help menu in QuickTime) for instructions.  
Once the QT Text file has been created, follow the following procedures to com-
plete the captioning process.

Converting the Captioned File

After developing the synchronized text transcript, you must convert this file into a 
QuickTime movie.

Begin QuickTime and select “Import” from the File menu.

Navigate to the appropriate Qtext file that contains the captioned dia-
logue exported from MAGpie.  Depending on your system, this will 
generally appear with a .TXT file extension.

Select the file and click the Convert button.

You will then be prompted to save the file as a movie in a new location.  
Select the appropriate location on your computer.  Choose the “Options” 
button to change any of the import settings if appropriate.

Select “Ok” when you have the options selected.

Select “Save” to save captioned text file as a QuickTime movie.
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Import Options

The following suggestions have been made by the MAGpie working group at 
WGBH/NCAM regarding the text import selections:

Generally, the convention is to set the width of the caption area to be the same as 
the width of the video area.  If you do not know the dimensions of your video, 
you should find out by opening the video in QuickTime and choosing ‘Get Info’ 
from the ‘Movie’ menu.

The height of the caption area presents a problem. It is not recommended that you 
select ‘Use Best-Fit Height’.  Instead, specify a height that is larger than might 
seem necessary. For a set of captions with a maximum of three 14-point lines, 
a height of 75 pixels seems to work well.  Differences in the way Windows and 
Macintosh computers display fonts create obstacles to the creation of a cross-plat-
form caption display.

Other options in this dialog include anti-alias for smooth font scaling, drop shad-
ow for a 3D font effect, and keyed text for captions that overlap video and need a 
transparent background to allow the video to show through.

Adding the Captions

Open the captioned movie and choose “Select All” from the Edit menu.  
Choose “Copy”.

Open the original, uncaptioned multimedia presentation in a new Quick-
Time window.

Before pasting the copied text, make sure the QuickTime player sliders 
are located at the beginning of the multimedia presentation.  The sliders 
are located above the QuickTime player controls.

Select Edit and then select “Add”.  The captioned region will first 
appear in the upper part of the QuickTime player.  Positioning of the 
captioned region will be addressed in the next section.

Positioning the Captions

Once the captions have been placed into the original multimedia presentation, it 
may necessary to position the captions in better location.

Select Window from the menu bar, and choose “Get Movie Properties”.

Select the entry called “Text Track” and choose the tab titled “Visual 
Settings”.

In the Offset fields, enter a value into the second offset field (this is 
the height from the top).  Enter a value equal to or just greater than the 
actual height of the movie.  This will cause the captioned text region to 
move to the bottom region of the QuickTime player and underneath the 
original movie.
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Once the “Text Track” region is in the correct location, close out of the 
Movie Properties window to return to the QuickTime player.

Save the QuickTime movie.  It is recommended to save the movie as a self-con-
tained movie with a different file name to distinguish this version from the uncap-
tioned version (e.g., mymovie_cap.mov).

Adding a Caption Toggle

In some cases, it may be beneficial to allow users to be able to toggle the captions 
on or off from within the QuickTime player.  You can add this toggle function by 
first downloading the caption toggle sprite from http://www.whitanderson.com/
macaw/toggle/toggle.htm

You will need to unzip/extract the actual toggle movie from the downloaded file.  
This is (essentially) a simple QuickTime movie that you can position within your 
captioned movie to enable or disable the appearance of the captions.

Open your captioned movie presentation in QuickTime Pro and the 
“toggle_caption.mov” file from the website.

In “toggle_caption.mov”, choose Edit > Select All and then choose Edit 
> Copy.

In the captioned movie file, choose Edit > Add to Selection and Scale.

Open the Movie Properties in your captioned movie (Window > Show 
Movie Properties).  Change the name of the Text Track to “caption”.  
Position the “toggle_caption” track using the Visual Settings tab (the 
lower left-corner of the player is generally appropriate).

Close the Movie Properties window and click on the “CC” button in 
your movie.  This should show or hide the caption region of the movie.  
Remember to save your movie.
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Flash Captioning

ccPlayer
The ccPlayer is a simple Flash SWF that displays a FLV movie with a captioning 
region and play/pause buttons beneath the original movie.  The ccPlayer is com-
posed of two parts: a HTML file (that can be edited); and a SWF file that provides 
the captioning region and interactive buttons.  If you are not familiar with devel-
oping Flash-based presentations and wish to deliver a video using Flash video, the 
ccPlayer interface allows a Web page author to edit the necessary parameters to 
complete a captioned video without learning the Flash authoring tool.

Download and unzip the ccPlayer from the NCAM website at:
http://ncam.wgbh.org/webaccess/ccforflash/ccplayermain.html

Editing the ccPlayer File

The ccPlayer will include the files ccPlayer.html and ccPlayer.swf.  The ccPlayer.
html file is the file that can be edited to include your video and caption file.  Cap-
tion files may be in either a DFXP format (Distribution Format Exchange Profile, 
W3C’s timed-text format) or a QT text file (timed-text file used by the Apple 
QuickTime player).  The DFXP format and QT text file can be created by MAG-
pie 2.0.3.  QT text files can also be created with Macaw.

Open the ccPlayer.html file in a Web editing tool (Dreamweaver, Note-
pad, etc.).

Edit both the value of the param name=”movie” in the <object> tag and 
the src= in the <embed> tag to the following values.

Change the ccVideoName= parameter to be the name of your Flash 
video and change the ccCaptionFilename= parameter to the name of 
your caption file.

Edit the remainder of the Web page to include the appropriate informa-
tion.

There are additional parameters that you can edit in order to customize the presen-
tation of your Flash movie.  A list of the different parameters can be found at:
http://ncam.wgbh.org/webaccess/ccforflash/ccPlayerHelp.html
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CC for Flash
The CC for Flash component is used to display the captions for a Flash presenta-
tion.  This component is installed into the Flash authoring application and can be 
utilized to with various objects to provide captions for audio or video content.  
The use of the CC for Flash component assumes some knowledge of the Flash 
authoring environment and provides additional options for the usage and custom-
ization of the captioning tool.

Download and unzip the CC for Flash kit from the NCAM website at:
http://ncam.wgbh.org/webaccess/ccforflash/

Installing the CC for Flash component

After downloading and unzipping the CC for Flash kit from NCAM, the folder 
will contain a CCforFlash.mxp file.  Use the Extension Manager to install this file 
into your Flash authoring tool.  This will include the CCforFlash component into 
the Components library in the Flash application.

Using CC for Flash

Place an instance of the FLV Playback – Player 8 component on the 
stage.  This is your video presentation.  In the Properties tab, provide 
an Instance Name.  In the Parameters tab, choose a skin (these are the 
interactive buttons that can be used to control playback).

Place an instance of the CCforFlash component below the video play-
back region.

In the Parameters tab of the CCforFlash component, set the “Choose the 
Object type to sync to” and “Object name and path” fields.  The “Object 
name and path” field will be the Instance Name of the FLV Playback 
component.

Identify the “Caption filename” field with the name of the caption file 
you wish to use.  The caption file may be in either a DFXP or QT text 
format.  DFXP formatted files must contain the extension .xml at the 
end of the filename.

Test your presentation and change any of the parameters of either the 
CCforFlash or the FLV Playback component as necessary.

If you are using Adobe Flash CS 3, you may not need the CC for Flash compo-
nent.  Look up the included Flash playback skins (these include the controls for 
playback) in Flash CS 3 for a skin that already includes a captioning option.

1.

2.

�.

4.

5.
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Playing the Media Clip with Captions

Each media player (i.e., Windows Media Player, RealPlayer, and QuickTime) 
controls the presentation of captioned dialogue using different methods.  Digital 
media can be closed captioned, meaning the end-user has the capacity to view the 
captioned dialogue if they so desire.

Windows Media Player
To display captions from within Windows Media Player (version 7 and above), 
follow these steps.

Select View from the menu bar.

Under the Now Playing Tools option, select Captions.

Captions should now be visible on the lower part of the media player.

If you are playing back the movie from your local hard drive, it may be necessary 
to set Window’s Media player to show local captions.

RealPlayer
To turn on Captions in the RealOne Player:

Select “Tools” from the menu bar.

Select “Preferences”.

On the left menu region (under “Category”), choose “Content”.

In the right display area, under “Accessibility”, select the checkbox that 
says, “Use supplemental text captioning when available”.

Choose “OK” to return to the main interface.

1.

2.

�.

1.

2.

�.

4.

5.
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Captioning Styles and Conventions

Introduction
(Adapted from the Captioned Media Program, www.cfv.org )

The process of captioning is not an exact science.  Rather, the individual tran-
scribing the audio track of the video clip must make decisions as to how the audio 
information should be appropriately rendered.  Placement of captions on-screen 
are somewhat dependent upon screen action, the number of speakers, or the man-
ner in which the speaker is communicating.  The information below is a combina-
tion of elements that are generally applied to television and broadcast captioning 
and have been adapted to be appropriate for digital captioning.

The information contained within this section was adapted from the Captioning 
and Accessibility Information white paper produced by the Captioned Media Pro-
gram.  For a complete digital or paper copy of these guidelines, visit:
http://www.cfv.org/caai.asp

Text

Caption Placement

Caption placement (vertical and horizontal) refers to the location of captions on 
the screen.  Placement must not interfere with existing visuals/graphics such as 
maps, illustrations, names of countries, job titles, or names of speakers.  Should 
interference occur, captions should be placed at the top of the screen.  If placing 
captions at the top of the screen also interferes with visuals/graphics, place cap-
tions elsewhere on the screen.

It is important to recognize the following information as guidelines for captioning 
Web-based video or multimedia clips.  These guidelines are based on the styles 
and methods generally used in the television industry and may not fulfill all the 
needs due to differences in Web-based video and broadcast video.  It is recom-
mended that those captioning for the Web, use this information as a guide as to 
properly present transcribed audio content.

Captions that contain 2 or more lines should be left-aligned.

This is an example of captioning

aligned to the left.
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In general, place captions on two lines instead of one long line of text.

Acceptable:

The quick brown fox

jumped over the lazy dog.

Unacceptable:

The quick brown fox jumped over the lazy dog.

If the captioned text is the same for both lines, indent the second line.

It was a dark and stormy night.

	 It was a dark and stormy night.

Presentation Rate
The presentation rate is the number of words per minute that are displayed on-
screen.  Generally speaking, this should be approximately 120 words per minute 
for middle-level educational groups.  For upper-level educational videos, it is 
permissible to be above the 120 words per minute rate.

For children, caption information may be presented at the 150-160 words per min-
ute rate whereas adult level videos may be presented at near verbatim rate.  Try to 
keep captions on the screen for at least two seconds.

Presentation rate is ignored when a famous speaker is quoted or the captioned dia-
logue is a poem, song lyrics, or another published literary work.  For these situa-
tions, it is important the captioned information is presented verbatim.

Language Mechanics
The English language contains many rules (and exceptions) that specify the 
format of grammar and punctuation and the spelling of words.  When beginning 
a captioning project, it is recommended to have available several dictionaries for 
reference.  The Captioned Media Program uses Random House Webster’s Un-
abridged Dictionary and the American Heritage Dictionary.  It may also be useful 
to have a reference book for different language styles (e.g., American Psychologi-
cal Association Manual of Style, Chicago Manual of Style, etc.).

Consistency

When spelling or formatting the captioned dialogue, maintain consistency 
throughout the video.  For instance, if a word is hyphenated in the beginning seg-
ment of the video, maintain the hyphenation throughout the video clip.
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Capitalization

The name of a speaker should be capitalized in the video.  However, do not capi-
talize the identification of a speaker.

Capitalization example:

His name is Frank.

He is a computer specialist.

Grammar

A contraction should be represented on-screen in the manner in which the contrac-
tion was spoken.  Avoid using contractions unless it is explicitly spoken in the 
dialogue.

Grammer example:

Make sure you submit the forms,

files, documents, et cetera.

Punctuation

Using punctuation correctly provides the viewer with a clear understanding of 
the dialogue and the contextual meaning of the spoken information.  The cap-
tioned dialogue can contain “errors” that would not be allowed in written text.  
For instance, run-on sentences or incomplete sentences may be perfectly valid for 
captioned dialogue, but would be considered unacceptable in written text.

Standard punctuation marks can be used to convey emotion or tone.  Using mul-
tiple punctuation marks can communicate strong emotion for necessary dialogue.

Multi-punctuation example:

Run away!!!!

Stop that man!!!!

To communicate that the on-screen speaker is screaming, use all capital letters.

Screaming example:

JUMP!!

If the on-screen speaker stutters, caption the dialogue verbatim using dashes be-
tween each letter.
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Stutter example:

Th-th-th-the quick br-br-brown fox

Special Considerations
Special considerations identify those elements that are not necessarily covered by 
normal use of the English language or are specific to a particular video presenta-
tion.  

Sound Effects

For sound effects or onomatopoeia, use the lowercase format.  If the sound effect 
or onomatopoeia includes a proper name, then it is permissible to use capitaliza-
tion for that proper name.

Sound example:

[horn honking]

beep-beep

If the source of the sound is clearly understood, then it is not necessary to have 
the source of the sound identified.  However, if the source of the sound is not ap-
parent or is off-screen, then it is necessary to place the source of the sound within 
brackets.  Off-screen sounds should be italicized.

Incorporating sounds effects into the captioned information can provide a better 
understanding of the video information presented.  It is important, however, to 
distinguish between sound effects that provide meaning about the video and sound 
effects that may compete with the spoken dialogue.  The presentation rate of the 
captioned dialogue and the use of sound effects must be balanced in such a way 
that the use of both enhances the viewing and comprehension of the video.

Numbers

Communicating numbers in a text format often introduces inconsistencies in the 
manner in which the information is displayed.  In general, numbers between one 
and ten should be spelled out, whereas numbers greater than ten should expressed 
in numerical format.  Numbers that contain greater than five digits should also 
include a comma to easily communicate amount.

Number example:

He had three bananas.

She gave $10,000 to the school.

If the number begins a sentence, then it is permissible to spell out the numerical 
value of the amount.
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Dates

Correct display of dates is necessary depending on the context in which the date 
information is spoken.  When the date and month is mentioned (i.e., no year), then 
using “th”, “st”, or “nd” is necessary.

No date-year example:

His birthday is on July 3rd.

When the day, the month, and the year are spoken, use only the numeral for the 
day (even if the “th”, “st”, or “nd” is spoken).

With date-year example:

The conference began

on July 12, 1988.

Decades, or periods of time, should not include the “’s” format.  Rather, the “s” 
should be appended to the end of the year.

Period of time example:

Where were you

in the 1970s.

Monetary amounts

Use the cents (¢) symbol for US monetary amounts less than one dollar.  Use the 
dollar ($) symbol for monetary amounts exceeding one dollar.

Monetary example:

I owe you 47¢.

Give me $13.

Measurements

When captioning measurements, do not use symbols or abbreviations for units of 
measure.  Instead, spell out the full word (e.g., “yards”, “inches”, “cups”, etc.) of 
the measurement.  However, it is permissible to use common abbreviations for 
measurements if spoken in a shortened form.
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Measurement example:

The window opening is 5’4”.

I need 5 cups of molasses.
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Basic Captioning Terms

Off-line captioning
Captioning that is produced after a video segment has been recorded.  A captioner 
watches the video recording and creates captions, paying attention to the timing 
and screen placement of each caption.  The captions are usually then recorded on 
a videotape with the program picture and sound before the program is broadcast 
or distributed.  Most captioned programming is produced off-line.

Real-time captioning
Captions that are simultaneously created and transmitted during a video program 
or conference.  This type of captioning is most frequently used for live programs, 
including news shows and sporting events.  A trained stenotypist, acting in much 
the same way as a courtroom reporter, enters the spoken content by typing phonet-
ic codes on a special keyboard that permits high-speed transcription.  A computer, 
using custom software, then very quickly translates the phonetic codes into proper 
words.  In order to display the words as quickly as possible after they are spoken, 
most realtime captioning is shown in a scrolling style.

Closed captions
Captions that appear only when special equipment called a decoder is used.  
Closed captioning is typically used for broadcast television and for videocassettes 
of movies that are widely distributed.  Closed captioning allows caption users 
(people who are deaf or hard of hearing) to enjoy the same broadcast and pre-re-
corded video materials that other television viewers enjoy.

Open captions
Captions visible without using a decoder.  When a video is open captioned, the 
captions are permanently part of the picture.  Open captions are advised for any 
situation where a decoder may be difficult to obtain or operate (for example, in a 
hotel, convention center, or museum).  For this reason, open captioning is recom-
mended for training and promotional videos.

Closed caption decoder
Equipment that decodes the captioning signal and causes captions to appear on 
the screen.  In the 1980s and early 1990s, closed caption decoders were usually 
separate appliances that connected to the television set, VCR, and/or cable con-
verter box.  Since July 1, 1993, all television receivers with screens 13 inches or 
larger manufactured for sale in the United States must have built-in closed caption 
decoders, and the additional appliance will not be needed for these sets.



Captioning Web-based Media

43

Roll-up and Pop-On captions
These are the two main styles in which captions may appear.  Roll-up captions 
scroll onto and off the screen in a continuous motion.  Pop-on captions do not 
scroll; the words display and erase entirely together.  Pop-on captions are used for 
most off-line captioning.  Roll-up captions are used for most real-time captioning.
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Web Captioning Resources

MAGpie
http://ncam.wgbh.org/webaccess/magpie/

Hi-Caption
http://www.hisoftware.com/hmcc/index.html

Macaw
http://www.whitanderson.com/macaw/

Windows Media Player

Technical information on SAMI
http://www.msdn.microsoft.com/library/default.asp?url=/library/en-us/dnwmt/
html/wmp7_sami.asp

WebM - Captioning Windows Media
http://www.webaim.org/techniques/captions/windows/

RealPlayer
http://www.real.com

WebAIM - Captioning RealPlayer
http://www.webaim.org/techniques/captions/real/

QuickTime
http://www.apple.com/quicktime/

Center for Instructional Technology Accessibility - QuickTime Cap-
tioning
http://cita.rehab.uiuc.edu/quicktime/

WebAIM - Captioning for QuickTime
http://www.webaim.org/techniques/captions/quicktime/

Flash

CC For Flash
http://ncam.wgbh.org/webaccess/ccforflash/index.html
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CC For Flash Help
http://ncam.wgbh.org/webaccess/ccforflash/CCforFlashHelp.html

ccPlayer
http://ncam.wgbh.org/webaccess/ccforflash/ccplayermain.html

ccPlayer Help
http://ncam.wgbh.org/webaccess/ccforflash/ccPlayerHelp.html

Adobe Flash CS3 Captioning
http://www.adobe.com/accessibility/products/flash/captions.html

Captionate
http://www.buraks.com/captionate/

Styles and Markup for Captioned Dialogue

WGBH
http://main.wgbh.org/wgbh/pages/captioncenter/ccstyles.html

Captioned Media Program
http://www.cfv.org
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