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Macaw 
 

Publisher: 
Whit Anderson 
http://www.whitanderson.com/macaw/ 
 
 

System Requirements: 
1. Apple OS 9 or Apple OS X 10.2 and above 
2. Windows 2000/XP 
3. QuickTime (QuickTime Pro highly recommended) 

 
 
 

Description: 
Macaw is an easy to use captioning tool designed for use with the QuickTime media format.  
Macaw allows users to create or import a transcript into the Macaw interface and then 
synchronize the transcript with the audio track of the QuickTime movie.  Once the text 
content has been synchronized with the multimedia presentation, Macaw creates a new "text" 
movie that can be then overlaid upon the uncaptioned multimedia presentation.  Macaw 
provides several additional utilities, such as the Macaw Track Manager and Toggle Buttons, 
that streamline the production and presentation of captioned QuickTime media. 
 
Macaw is different from other captioning tools in that creates a text track that is then 
imported into QuickTime Pro to create the "text" movie.  Other captioning tools (e.g., 
MAGpie or Hi-Caption) can export synchronized transcripts as QuickTime compatible SMIL 
files as well as handle multiple media formats.  Instead of a "multiple-in/multiple-out" 
captioning tool, Macaw is designed to support captioning for QuickTime media for both 
Apple and PC systems. 
 
 

Getting Started 
To use Macaw to caption a QuickTime video, it is necessary to have the movie and transcript 
set properly in order to streamline the production process. 
 

Setting up the QuickTime video 
Set the QuickTime video to 320x240 to fit within the Macaw captioning interface.  If the 
video is larger than 320x240, then you can set the video to appear as "Half-Size" (requires 
QuickTime Pro). 
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Setting up the text transcript 
The transcript should be a text-only file (ASCII) as created from Notepad, TextEdit, etc. or 
saved from a word processing program as "Text-only".  Create the transcript such that there 
is a blank line between the text phrases. 
 
Example: 
 

We begin the process, 
 
in today's demonstration, 
 
by scanning the documents 
 
on the Xerox DocuCenter 320. 

 
 
If you wish to combine several lines together, place a hard-return at the end of the phrase 
where you wish to split the sentence.  In the example below, the first two lines would appear 
at the same time in the captioned video, followed by the second two lines of text. 
 
Example: 

 
We begin the process, 
in today's demonstration, 
 
by scanning the documents 
on the Xerox DocuCenter 320. 

 
 
Note - For 320 x 240 and above screen resolution, two lines of text and approximately 20 
characters per line (4-6 words) seems to work well. 
 

Setting the Text Style 
Macaw will allow you to set some basic text formatting parameters for the captioned movie.  
After you have selected the video and text transcript and BEFORE you caption the movie, 
you can set the text style options.  Press the Make Style Choices button in the Macaw 
interface to access the text style options. 
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Within the style options screen, several of the options you can change are the: 
 

• Text style – plain, bold, italic 
• Justification – left, center, right 
• Text size – 8 pt. to 24 pt. 
• Font – Arial, Helvetica, Times 
• Caption Height – 12 pt. to 64 pt. 

 
There are several additional preset values.  To create captioned videos for computer or iPod 
viewing, videos at 320 x 240 screen-resolution and with the transcript arranged in the two-
line format (with 4-6 words per line), then the following parameters should be sufficient: 
 

• Justification:  Center 
• Type Size:  18 pt. 
• Type Style:  Plain 
• Font:  Arial 
• White Text on Black Background 
• Caption Height: 48 pt. 
• Caption Width: 320 
• Time Scale: 30 

 
For those who are comfortable editing the QT Text file, it is possible to customize the Type 
Size and Caption Height values to something other than the preset Macaw values. 
 

Synchronizing the Transcript and Movie 
Once you have the QuickTime movie and the text transcript prepared, Macaw can import 
these assets and begin the process of synchronizing the transcript with the QuickTime movie.  
While the movie is playing, you will synchronize the appearance of the text information with 
the audio dialogue of the movie.  Remember to change the text style options before you 
begin the captioning process. 
 
Note – Pressing Quit in any of the Macaw screen interfaces will cause the program to close. 
 

1. Open the Macaw interface and choose the movie and text transcript. 
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2. Press the Play button in the QuickTime movie interface to begin the movie. 
 
3. Press the Mark Sync button (or "m" on the keyboard) to synchronize the screen text 

with the spoken dialogue.  If you need to pause the movie, press the Pause button in 
the QuickTime movie interface. 

 

 
 
 
4. Once the movie has been synchronized, press the "Save the Text Track to a File" 

button.  This saves the text transcript with embedded time code.  The default file 
name will be "track.txt". 
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Adding Captions to the Original Movie 
After developing the synchronized text transcript, you must convert this file into a 
QuickTime movie. 
 

1. Begin QuickTime Pro.  Choose File > Open File and navigate to the "track.txt" file of 
your movie.  (Hint: you may need to set the "Files of type:" selection to All Files) 

 
2. The "track.txt" file will open in a QuickTime player.  Choose Edit > Select All and 

then choose Edit > Copy. 
 
3. Open the original (uncaptioned movie) in QuickTime Pro.  Ensure that playback head 

is at the start of the video.  Choose Edit > Add to Movie to insert the copied text 
movie. 

 

 
 
 
The added text movie may be added to the top of the uncaptioned movie in the QuickTime 
player interface.  Once the text track movie is added to the original movie, you can move the 
text track around the QuickTime interface and position the necessary elements. 
 

1. Choose Window > Show Movie Properties in QuickTime Pro to open the movie 
properties window.  You should have a Sound Track, Video Track, and Text Track 
visible in the top portion of the interface. 

 
2. Select Text Track and choose the "Visual Settings" tab in the lower portion of the 

window. 
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3. In the "Offset" edit boxes, enter in the total height of the movie in the second box 
(this is the vertical offset).  This tells the text movie clip to "move down" the 
specified number of pixels.  Ideally, the text movie clip should reside just beneath the 
uncaptioned movie. 

 

 
 
 
4. Close the Movie Properties window to return to the original movie interface.  Your 

movie captions should now appear under the original movie.  Play back the movie to 
verify the captions display correctly in the lower region. 

 
5. Save the newly captioned movie as a Self-Contained movie (File > Save As…).  It is 

recommended to use a slightly different file name (e.g, mymovie_cap.mov) to 
distinguish between the captioned version and the uncaptioned version. 

 
Note - If you do not know the height of the movie, you can determine the uncaptioned movie 
height by selecting the Video Track in the Movie Properties window and then the Visual 
Settings.  The movie dimensions will be listed in the Transformation region.  Alternatively, 
you can select the QuickTime player of the uncaptioned video and choose Window > Show 
Movie Info for the height and width of the uncaptioned movie. 
 
 

Adding Caption Toggle to QuickTime movies 
In some cases, it may be beneficial to allow users to be able to toggle the captions on or off 
from within the QuickTime player.  You can add this toggle function by first downloading 
the caption toggle sprite from http://www.whitanderson.com/macaw/toggle/toggle.htm .  You 
will need to unzip/extract the actual toggle movie from the downloaded file.  This is 
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(essentially) a simple QuickTime movie that you can position within your captioned movie to 
enable or disable the appearance of the captions. 
 

1. Open your captioned movie presentation in QuickTime Pro and the 
"toggle_caption.mov" file from the website. 

 
2. In "toggle_caption.mov", choose Edit > Select All and then choose Edit > Copy. 
 
3. In the captioned movie file, choose Edit > Add to Selection and Scale. 
 
4. Open the Movie Properties in your captioned movie (Window > Show Movie 

Properties).  Change the name of the Text Track to "caption".  Position the 
"toggle_caption" track using the Visual Settings tab (the lower left-corner of the 
player is generally appropriate). 

 

 
 
 
5. Close the Movie Properties window and click on the "CC" button in your movie.  

This should show or hide the caption region of the movie.  Remember to save your 
movie. 
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Captioning Styles and Conventions 

Introduction 
(Adapted from the Captioned Media Program, www.cfv.org) 
 
The process of captioning is not an exact science.  Rather, the individual transcribing the 
audio track of the video clip must make decisions as to how the audio information should be 
appropriately rendered.  Placement of captions on-screen are somewhat dependent upon 
screen action, the number of speakers, or the manner in which the speaker is communicating.  
The information below is a combination of elements that are generally applied to television 
and broadcast captioning and have been adapted to be appropriate for digital captioning. 
 
The information contained within this section was adapted from the Captioning and 
Accessibility Information white paper produced by the Captioned Media Program.  For a 
complete digital or paper copy of these guidelines, visit:  http://www.cfv.org/caai.asp 
 

Text 
Caption Placement 
Caption placement (vertical and horizontal) refers to the location of captions on the screen.  
Placement must not interfere with existing visuals/graphics such as maps, illustrations, 
names of countries, job titles, or names of speakers.  Should interference occur, captions 
should be placed at the top of the screen.  If placing captions at the top of the screen also 
interferes with visuals/graphics, place captions elsewhere on the screen. 
 
It is important to recognize the following information as guidelines for captioning Web-
based video or multimedia clips.  These guidelines are based on the styles and methods 
generally used in the television industry and may not fulfill all the needs due to differences in 
Web-based video and broadcast video.  It is recommended that those captioning for the Web, 
use this information as a guide as to properly present transcribed audio content. 
 
Captions that contain 2 or more lines should be left-aligned. 
 
Example: 
This is an example 
of captioning aligned to the left. 
 
In general, place captions on two lines instead of one long line of text. 
 
Example: 
The quick brown fox 
jumped over the lazy dog. 
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Inappropriate: 
The quick brown fox jumped over the lazy dog. 
  
If the captioned text is the same for both lines, indent the second line. 
 
Example: 
It was a dark and stormy night. 

It was a dark and stormy night. 
 
 
If the on-screen individual is dreaming or thinking, identify the description in brackets and 
use italicized captions above the speaker’s head. 
 
Example: 
[dreaming] 
I wish I had a new Porsche. 
 

Presentation Rate 
The presentation rate is the number of words per minute that are displayed on-screen.  
Generally speaking, this should be approximately 120 words per minute for middle-level 
educational groups.  For upper-level educational videos, it is permissible to be above the 120 
words per minute rate. 
 
For children, caption information should be presented at the 150-160 words per minute rate.  
Adult level videos can be presented at near verbatim rate, but not exceed 225 words per 
minute.  Additionally, no caption should remain on-screen less than 2 seconds. 
 
Presentation rate is ignored when a famous speaker is quoted or the captioned dialogue is a 
poem, song lyrics, or another published literary work.  For these situations, it is important the 
captioned information is presented verbatim. 
 
If editing is necessary to maintain a proper rate of presentation, the edited dialogue should 
retain as much of the original meaning and content as the unedited dialogue.  Editing should 
only be performed if the captioning dialogue rate exceeds the rate of presentation.  Efforts to 
“speed up” the presentation of captioned dialogue are inappropriate and should not be 
adopted. 
 

Language Mechanics 
The English language contains many rules (and exceptions) that specify the format of 
grammar and punctuation and the spelling of words.  When beginning a captioning project, it 
is recommended to have available several dictionaries for reference.  The Captioned Media 
Program uses Random House Webster’s Unabridged Dictionary and the American Heritage 
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Dictionary.  It may also be useful to have a reference book for different language styles (e.g., 
American Psychological Association Manual of Style, Chicago Manual of Style, etc.). 
 

Consistency 
When spelling or formatting the captioned dialogue, maintain consistency throughout the 
video.  For instance, if a word is hyphenated in the beginning segment of the video, maintain 
the hyphenation throughout the video clip. 
 

Capitalization 
The name of a speaker should be capitalized in the video.  However, do not capitalize the 
identification of a speaker. 
 
Example: 
His name is Frank. 
He is a computer specialist. 
 

Grammar 
A contraction should be represented on-screen in the manner in which the contraction was 
spoken.  Avoid using contractions unless it is explicitly spoken in the dialogue. 
 
Example: 
Make sure you submit the forms, 
files, documents, et cetera. 
 

Punctuation 
Using punctuation correctly provides the viewer with a clear understanding of the dialogue 
and the contextual meaning of the spoken information.  The captioned dialogue can contain 
“errors” that would not be allowed in written text.  For instance, run-on sentences or 
incomplete sentences may be perfectly valid for captioned dialogue, but would be considered 
unacceptable in written text. 
 
Standard punctuation marks can be used to convey emotion or tone.  Using multiple 
punctuation marks can communicate strong emotion for necessary dialogue. 
 
Example: 
Run away!!!! 
Stop that man!!!! 
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To communicate that the on-screen speaker is screaming, use all capital letters. 
 
Example: 
JUMP!! 
 
Special emphasis can be given to nonessential information using double dashes, or a single 
long dash, rather than using commas to separate information. 
 
Example: 
The small boat sailed all the way from 
London, England – 2,500 nautical miles. 
 
If the on-screen speaker stutters, caption the dialogue verbatim using dashes between each 
letter. 
 
Example: 
Th-th-th-the quick br-br-brown fox 
 

Special Considerations 
Special considerations identify those elements that are not necessarily covered by normal use 
of the English language or are specific to a particular video presentation.   
 
Sound Effects 
For sound effects or onomatopoeia, use the lowercase format.  If the sound effect or 
onomatopoeia includes a proper name, then it is permissible to use capitalization for that 
proper name. 
 
Example: 
[horn honking] 
beep-beep 
 
If the source of the sound is clearly understood, then it is not necessary to have the source of 
the sound identified.  However, if the source of the sound is not apparent or is off-screen, 
then it is necessary to place the source of the sound within brackets.  Off-screen sounds 
should be italicized. 
 
Incorporating sounds effects into the captioned information can provide a better 
understanding of the video information presented.  It is important, however, to distinguish 
between sound effects that provide meaning about the video and sound effects that may 
compete with the spoken dialogue.  The presentation rate of the captioned dialogue and the 
use of sound effects must be balanced in such a way that the use of both enhances the 
viewing and comprehension of the video. 
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Numbers 
Communicating numbers in a text format often introduces inconsistencies in the manner in 
which the information is displayed.  In general, numbers between one and ten should be 
spelled out, whereas numbers greater than ten should expressed in numerical format.  
Numbers that contain greater than five digits should also include a comma to easily 
communicate amount. 
 
Example: 
He had three bananas. 
She gave $10,000 to the school. 
 
If the number begins a sentence, then it is permissible to spell out the numerical value of the 
amount. 
 

Dates 
Correct display of dates is necessary depending on the context in which the date information 
is spoken.  When the date and month is mentioned (i.e., no year), then using “th”, “st”, or 
“nd” is necessary. 
 
Example: 
His birthday is on July 3rd. 
 
When the day, the month, and the year are spoken, use only the numeral for the day (even if 
the “th”, “st”, or “nd” is spoken). 
 
Example: 
The conference began 
on July 12, 1988. 
 
Decades, or periods of time, should not include the “’s” format.  Rather, the “s” should be 
appended to the end of the year. 
 
Example: 
Where were you 
in the 1970s. 
 

Monetary amounts 
Use the cents (¢) symbol for US monetary amounts less than one dollar.  Use the dollar ($) 
symbol for monetary amounts exceeding one dollar. 
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Example: 
I owe you 47¢. 
Give me $13. 
 

Measurements 
When captioning measurements, do not use symbols or abbreviations for units of measure.  
Instead, spell out the full word (e.g., “yards”, “inches”, “cups”, etc.) of the measurement.  
However, it is permissible to use common abbreviations for measurements if spoken in a 
shortened form. 
 
Example: 
The window opening is 5’4”. 
I need 5 cups of molasses. 
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Resources 
 
QuickTime 

For technical information for creating captioned QuickTime movies. 
http://www.quicktime.com 

 
http://ncam.wgbh.org/news/webnews16.html 

 
http://ncam.wgbh.org/richmedia/mediatypes/QT.php 
 
 
Styles and Markup for Captioned Dialogue 

http://www.cfv.org 
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